Ubuntu 系统 apt 报错:relocation error

今天更新系统 然后启动软件就起不来了,报错误如下
/usr/lib/apt/methods/http: relocation error: /usr/lib/x86_64-linux-gnu/libgnutls.so.30: symbol _idn2_punycode_decode version IDN2_0.0.0 not defined in file libidn2.so.0 with link time reference
意思是在libgnutls.so这个软件有个变量未定义。导致软件无法正常运行。
查阅资料 可以降级到之前正常版本。具体原因未知 只能等官方修复这个问题了
下载deb https://share.weiyun.com/541Scvk
然后执行命令 sudo dpkg -i libidn2-0_2.0.5-1_amd64_1.deb。等待安装完毕。
再次执行sudo apt update此时可以正常运行。

南城以南
讨论数量: 0
(= ̄ω ̄=)··· 暂无内容!

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!