快速入门

未匹配的标注

要求

  • Go 1.11 及以上版本 (Go modules 要求)

很快将不再支持Go 1.7或Go 1.8。

安装

要安装 Gin 软件包,需要先安装 Go。

1.下载并安装 gin:

$ go get -u github.com/gin-gonic/gin

2.将 gin 引入到代码中:

import "github.com/gin-gonic/gin"

3.(可选)如果使用诸如 http.StatusOK 之类的常量,则需要引入 net/http 包:

import "net/http"

使用 Go modules 工具管理项目(Go modules 需要 go v1.11 及以上版本才支持)

1.创建项目并且 cd 到项目目录中 (也可以把项目放到你想放的任何地方,使用 go mod 的好处就是不必强制把项目放到 GOPATH 下了)

$ mkdir -p $GOPATH/src/github.com/myusername/project && cd "$_"

2.初始化 go mod

$ go mod init project

3.启动项目

$ go run main.go

开始

不确定如何编写和执行 Go 代码? 点击这里.

首先,创建一个名为 example.go 的文件

$ touch example.go

接下来, 将如下的代码写入 example.go 中:

package main

import "github.com/gin-gonic/gin"

func main() {
    r := gin.Default()
    r.GET("/ping", func(c *gin.Context) {
        c.JSON(200, gin.H{
            "message": "pong",
        })
    })
    r.Run() // 监听并在 0.0.0.0:8080 上启动服务
}

然后, 执行 go run example.go 命令来运行代码:

# 运行 example.go 并且在浏览器中访问 0.0.0.0:8080/ping
$ go run example.go

本文章首发在 LearnKu.com 网站上。

上一篇 下一篇
Summer
贡献者:2
讨论数量: 2
发起讨论 只看当前版本


licxisky
《Gin 框架中文文档》是不是可以考虑更新一下了?
1 个点赞 | 0 个回复 | 问答 | 课程版本 2019
勇敢的心
可以使用 gin 做游戏服务器吗?
0 个点赞 | 2 个回复 | 问答 | 课程版本 2019