Flutter iOS 中使用 Pod 集成第三方 Framework 后 Swift 编译错误

Flutter iOS 中使用 Pod 集成第三方 Framework 后 Swift 编译错误

附上Framework下载地址
下载: pan.baidu.com/s/1jzVmqHHJGqtKD8pVt... 提取码: 6rap
按照里面的文档给出的方法集成,无法通过编译,Framework 官方给出的 Demo 可以正常编译运行
修改过 Vaild Architchtures 删除了里面的 arm64 arm64e 没有效果
百度了几天毫无头绪
请问有遇到过这样的问题的人吗?该怎么解决?

讨论数量: 1

问题已解决。写出解决办法留给以后可能会遇到同样问题的人。
我对照了Flutter提供的Framework文件,发现下载的Framework文件中多了.swiftmodule目录删了这个目录就好了,因为项目配置改来改去被我搞烂了所以重新建了一个项目就没问题了。
然后遇到了一个无法打包的问题,修改了 Architectures 和 Vaild Architectures 为 arm64 打包通过

1个月前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!