hyperf 在 phpstrom 中语法怎么能够得到支持,安装了 swoole 还是报红,请各位指点!

看了几天hyperf文档的我,心情激动不已,今天一早,正好闲下来,打算使用hyperf做个小项目,把项目什么都安装好,顺利的跑起后,我在phpstrom中去编写代码的时候发现IDE貌似并不支持hyperf的语法,我刚开始以为是我的phpstrom没安装支持swoole语法的插件的原因,可是我安装后还是报语法问题,虽然不影响写代码,可是我有点强迫症,看着代码就很难受,具体样子是如图这样的:

hyperf在phpstrom中语法怎么能够得到支持,安装了swoole还是报红,请各位指点!
就连框架中自带的logger.php文件也是这样

hyperf在phpstrom中语法怎么能够得到支持,安装了swoole还是报红,请各位指点!
是我缺少了什么插件没安装么?请求各位指点一下!

犯二青年

犯二青年
犯二青年
最佳答案

报错原因是因为安装了:
file
这个Yii的插件,导致hyperf语法报错

1个月前 评论
讨论数量: 4

是不是有代码格式的插件导致的??

2个月前 评论
犯二青年 (楼主) 2个月前
了然、 (作者) 2个月前
犯二青年

file
@了然、 提示是这样的,我看了一下,只是说需要穿data过去,并没有限制数据类型,

file

2个月前 评论

没有遇到过这样的情况,可以检查下 Language level 是不是 PHP 7.2 +,如果是,你可以考虑先卸载你说的 laravel 的插件试试看

2个月前 评论
犯二青年 (楼主) 2个月前
犯二青年

报错原因是因为安装了:
file
这个Yii的插件,导致hyperf语法报错

1个月前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!