三级联动 只有 {{ name }} ?

有很认真的检查了三遍步骤 确定并没有什么疏漏再来提问的
file

而且看起来这个文件有很多错误 没有接触过vue 不太清楚是什么情况
file

这个是app.js文件
file

yarn 命令是成功的 componets中的 china-area-data 是手动git下载的 但是没什么用
file
大神 帮忙解答一下

《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
leo
最佳答案
  1. require('./components/SelectDistrict') 放到 window.Vue = require('vue') 下面
  2. npm run watch-poll 是否执行成功?
8个月前
讨论数量: 9
leo
  1. require('./components/SelectDistrict') 放到 window.Vue = require('vue') 下面
  2. npm run watch-poll 是否执行成功?
8个月前

@leo 抱歉 怎么久才给回复 我的watch-poll是一直在运行的 执行第一步之后 就可以出现效果了 就是不太明白是什么原理

8个月前
leo

@zxx123 没引入 Vue 之前就去调用 Vue 的方法肯定不对嘛

8个月前
thomas-fan

打开js调试,控制面板上应该会报错Vue is not define之类的,

file

按照这个顺序引入先引入Vue,再加载组件,教程没有说的太清楚

8个月前

@leo 谢谢,解决了相同的问题 之前也没有接触过vue,也刚刚接触laravel

7个月前

这种情况有可能是浏览器兼容问题,换成谷歌浏览器就好了,我踩过的坑

5个月前

@leo 我的也是 {{ name }} 。
vagrant@homestead:~/code/laravel-shop$ yarn add china-area-data
yarn add v1.7.0
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@1.2.4: The platform "linux" is incompatible with this module.
info "fsevents@1.2.4" is an optional dependency and failed compatibility check. E
[3/4] Linking dependencies...
warning " > sass-loader@7.1.0" has unmet peer dependency "webpack@^3.0.0 || ^4.0.
[4/4] Building fresh packages...
success Saved 1 new dependency.
info Direct dependencies
└─ china-area-data@4.0.0
info All dependencies
└─ china-area-data@4.0.0
Done in 51.07s.

npm run watch-poll 没错误 ,require('./components/SelectDistrict'), 也放在了vue下 F12 console没错误

2个月前
leo

@zhuwene 发一个新的帖子,贴出所有相关的截图

2个月前

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!