Flutter提示不支持dart:mirrors错误

flutter运行时提示“import of dart:mirrors is not supported in the current Dart runtime”

但全局搜索也没有发现什么地方导入了“dart:mirrors”。

之前运行flutter都是正常的,今天忽然就不行了,flutter新手,求解决方法。

导入一下这些库:

dependencies:
  flutter:
    sdk: flutter


  cupertino_icons: ^1.0.2
  # 获取设备id
  platform_device_id: ^0.1.1
  dio: ^4.0.0
  path_provider: ^1.6.28 # 文件路径管理
  permission_handler: ^5.1.0+2 # 检测权限,没有权限就申请
  flutter_sound: ^4.0.6 # 录音与播放
  shared_preferences: ^0.5.12+4 # 数据存储
  date_format: ^2.0.2 # 时间格式
  moor: ^4.3.2 # 数据库操作
  moor_generator: ^4.3.1 # 数据库操作依赖
  build_runner: ^2.0.4
  sqlite3_flutter_libs: ^0.5.0
  flutter_swiper: ^1.1.6
  device_info: ^1.0.0
  fluttertoast: ^8.0.7
讨论数量: 2

里面控制台应该有日志,告诉你在第几行的

3个月前 评论

请教一下这个问题你解决了吗?我这里也突然出现了这个问题 :sob:

1个月前 评论

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!