Yii2.012 版本与 PHP7.2 不兼容 (报错 Cannot use 'Object' as class name as...) 问题的处理方法

官方暂时没有没出其他办法,唯有升级版本

  1. 修改 composer.json
    "require" : {
      "yiisoft/yii2": "2.0.16"
    },
  2. 执行composer升级
    composer update yiisoft/yii2
_mars
讨论数量: 1

这是php7的特性,和yii2冲突了,根本解决方法就是升级框架。要么就把php的版本降到7.0

6天前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!