Python 在 20201010 之后的 pip3 install

在 2020 年 10 月 10 日之后 pip3 install 会发生错误:

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

astroid 2.4.2 requires lazy-object-proxy==1.4.*, but you'll have lazy-object-proxy 1.5.1 which is incompatible.


$ pip3 install xxx --use-feature=2020-resolver
本作品采用《CC 协议》,转载必须注明作者和本文链接
本帖由 Galois 于 6个月前 解除加精
讨论数量: 0
(= ̄ω ̄=)··· 暂无内容!