8.2. 安装运行环境

安装运行环境

接下来我们需要给新创建的服务器安装必要的运行环境,我们将通过一个脚本来安装,首先请确保通过 SSH 登录到了服务器上。

阿里云的按量付费服务器关机一段时间之后再开机,公网 IP 可能发生改变,需要仔细检查。如果发生改变需要在 Homestead 的 ~/.ssh/config 里加入对应的新 IP。

1. 执行安装脚本

由于该脚本只支持 Ubuntu 16.04,请确保你的服务器系统无误。

然后执行如下命令:

$ wget -qO- https://raw.githubusercontent.com/summerblue/laravel-ubuntu-init/master/download.sh - | bash

file

安装完毕之后会在屏幕上输出 Mysql 的 root 密码,请妥善保存。

同时按照屏幕上的指示,需要执行一下:

$ source ~/.bash_aliases

2. 初始化站点配置、目录

接下来我们需要创建一个新的 Nginx 站点用于 Laravel Sh...

本文章首发在 LearnKu.com 网站上。

为了保证课程的高品质,我们需要对课程进行收费。付费后 才能观看剩余内容。 购买

上一篇 下一篇
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
讨论数量: 33

Flourishing
老师,Ubuntu14.04 的系统有试过能不能安装这个安装脚本呢?
0 个点赞 | 12 个回复 | 问答 | 课程版本 5.5
月殇
电商进阶 java10 安装 失败
0 个点赞 | 12 个回复 | 问答 | 课程版本 5.5
坐忘
执行安装脚本没有提示 不知道是不是成功了
0 个点赞 | 7 个回复 | 问答 | 课程版本 5.5
logly_zhao
Elasticsearch 服务起不来,是否 java 配置有关?
0 个点赞 | 7 个回复 | 问答 | 课程版本 5.5
TravelerLi
安装失败的问题,求教
0 个点赞 | 6 个回复 | 问答 | 课程版本 5.5
小小的花花
老师这个安装脚本支持桌面版的 Ubuntu16 吗?
0 个点赞 | 6 个回复 | 问答 | 课程版本 5.5
Flourishing
关于启动 ES 的问题
0 个点赞 | 5 个回复 | 问答 | 课程版本 5.5
gyp719
安装不成功
0 个点赞 | 4 个回复 | 问答 | 课程版本 5.5
putixin
重启 nginx 后提示文件未找到?
0 个点赞 | 4 个回复 | 问答 | 课程版本 5.7
captainwong
Elasticsearch 安全性问题
0 个点赞 | 4 个回复 | 问答 | 课程版本 5.7
xuelong
安装脚本没有返回 MySQL root 密码
0 个点赞 | 3 个回复 | 问答 | 课程版本 5.8
能否通过此环境创建多个站点?
0 个点赞 | 3 个回复 | 问答 | 课程版本 5.7
iVerywang
数据库密码忘记了怎么办?
0 个点赞 | 3 个回复 | 问答 | 课程版本 5.5
ytkah
CentOS 有相关的版本吗
0 个点赞 | 3 个回复 | 问答 | 课程版本 5.5
myconch
请问新建的 Laravel-shop 数据库中没有 MySQL 表是什么原因?
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.8
gyp719
服务器装好了后,阿里云会提示很多漏洞
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.8
深入浅出
创建.ssh 文件夹后 Homestead 启动不了
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.8
huzhuolei
能否升级兼容 18.04 系统呀
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.7
JaydenHong
脚本安装不成功
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.7
iVerywang
远程连接 数据库 报错?
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
晓鹤
选的是美国的服务器,停在了 【正在初始化系统...】
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
bing_
packet_write_wait: Connection to 我的公网 IP port 22: Broken pipe
0 个点赞 | 1 个回复 | 分享 | 课程版本 5.8
wwwj
安装 Elasticsearch 能指定版本吗?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.8
wwwj
创建 MySQL 账户的时候显示密码不正确
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.8
mingzheng
为什么 MySQL 输入 root 密码总是提示错误
0 个点赞 | 1 个回复 | 分享 | 课程版本 5.5
zhaocrazy
更换公网 IP 后 连接失败 报以下错误
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.7
Flourishing
老师,商业项目使用 Ubuntu16.4 的系统多么?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
logly_zhao
Elasticsearch 安装后还需安装中文分词器
0 个点赞 | 1 个回复 | 分享 | 课程版本 5.5
小韩
8.2. 安装运行环境 安装问题?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5