6.7. 在 Heroku 上使用 PostgreSQL

Heroku 为 Laravel 应用提供了数据存储的功能,我们可以在 Heroku 上使用 MySQL 或 PostgreSQL 来进行数据存储。由于 Heroku 对 PostgreSQL 的支持比 MySQL 更好,因此本教程中将在 Heroku 上使用 PostgreSQL 来作为我们应用的数据库。

要在 Heroku 上使用 PostgreSQL,我们需要先安装 PostgreSQL 扩展。

$ heroku addons:add heroku-postgresql:hobby-dev

安装完成之后,Heroku 将为我们生成一个唯一的数据库 URL - DATABASE_URL,我们可以通过下面命令查看 Heroku 的所有配置信息:

$ heroku config

在本地开发中,我们使用了 MySQL 来作为数据库储存,但在 Heroku 环境上我们要改为使用 PostgreSQL 来作为数据库储存。因此在进行数据库设置时,我们需要对当前环境进行判断。如果环境为本地环境,则使用 MySQL 数据库,若为 Heroku 环境,则使用 PostgreSQL 数据库。我们可以通过为 Heroku 新增一个 IS_IN_HEROKU 配置项来判断应用是否运行在 Heroku 上。

$ heroku config:set IS_I...

本文章首发在 LearnKu.com 网站上。

为了保证课程的高品质,我们需要对课程进行收费。付费后 才能观看剩余内容。 购买

上一篇 下一篇
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 23

青风百里
解决一些在 Heroku 上使用 PostgreSQL 的疑惑
11 个点赞 | 3 个回复 | 问答 | 课程版本 5.5
HectorChan
Heroku run PHP artisan migrate 出错?
0 个点赞 | 44 个回复 | 问答 | 课程版本 5.5
zhbguoke
求助 Heroku run PHP artisan migrate 报错?
0 个点赞 | 9 个回复 | 问答 | 课程版本 5.5
Nay_said
执行 Heroku run PHP artisan migrate 报错怎么办?
0 个点赞 | 5 个回复 | 问答 | 课程版本 5.5
dwtmtdh
加了 getDbCofig 后,route:cache 报错?
0 个点赞 | 4 个回复 | 问答 | 课程版本 5.5
desmond
Heroku run PHP artisan migrate 出错,与上面提示不同!?
0 个点赞 | 4 个回复 | 问答 | 课程版本 5.5
crazy9115
可以跳过?
0 个点赞 | 3 个回复 | 问答 | 课程版本 5.5
MR_Z
线上不行,数据库都连不上。本地可以!为什么呢??
0 个点赞 | 3 个回复 | 问答 | 课程版本 5.5
leoshen
poison
安装 PostgreSQL 扩展报错 Error: Missing required flag
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.7
jingzhongwa
执行 Heroku run PHP artisan migrate 报错
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
jiangpanyue
頁面丟失?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
JackZhang
Heroku run PHP artisan migrate 为什么安装报错 Undefined index: driver,?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
Qiaokel
Heroku run PHP artisan migrate 出错? sql [22023]
0 个点赞 | 0 个回复 | 问答 | 课程版本 5.8
anningri
Heroku run PHP artisan migrate 提示 database "port=5432" does not exist
0 个点赞 | 0 个回复 | 问答 | 课程版本 5.7
anningri
Heroku 添加 PostgreSQL 报的一个错误
0 个点赞 | 0 个回复 | 问答 | 课程版本 5.7
老好人
如何在自己的 ECS 服务器上做一个类似 Heroku 的环境?
0 个点赞 | 0 个回复 | 问答 | 课程版本 5.5