6.5. 注册失败错误消息

显示表单错误信息

目前是我们尝试填写完表单,如果表单信息填写有误并提交,页面不会展示报错信息。Laravel 默认给我们提供了一种非常好的展示错误信息的方法,现在让我们来为应用加上提交失败时的错误信息展示。

resources/views/shared/_errors.blade.php

@if (count($errors) > 0)
  <div class="alert alert-danger">
      <ul>
          @foreach($errors-&g...

本文章首发在 LearnKu.com 网站上。

为了保证课程的高品质,我们需要对课程进行收费。付费后 才能观看剩余内容。 购买

上一篇 下一篇
《L01 基础入门》
我们将带你从零开发一个项目并部署到线上,本课程教授 Web 开发中专业、实用的技能,如 Git 工作流、Laravel Mix 前端工作流等。
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
贡献者:1
讨论数量: 31

aelephant
按教程操作需要补充如下才能显示效果:
5 个点赞 | 5 个回复 | 分享 | 课程版本 5.7
airsky
Laravel 6.0 安装 Laravel-Lang 方式有更新
4 个点赞 | 7 个回复 | 分享 | 课程版本 6.x
qq3943
请问如何对中文部分的验证消息改写?
2 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
justlovelmn
Composer require "overtrue/Laravel-lang:~3.0" 安装之后没效果?
0 个点赞 | 20 个回复 | 问答 | 课程版本 5.5
chuixiaojian
我掉入坑了?
0 个点赞 | 19 个回复 | 问答 | 课程版本 5.5
Rotor1996
添加语言包没效果,Laravel-lang 没作用?
0 个点赞 | 17 个回复 | 问答 | 课程版本 5.5
chuixiaojian
要如何升级项目的 PHP 呢?
0 个点赞 | 9 个回复 | 问答 | 课程版本 5.5
hustnzj
overtrue/Laravel-lang 是在哪里配置了包的自动注册呢?
0 个点赞 | 7 个回复 | 问答 | 课程版本 5.5
Tibbers
Composer 安装语言包 报错提示 内存不足 如何解决
0 个点赞 | 5 个回复 | 问答 | 课程版本 5.7
HYZR
alert 不显示,跳转显示 JSON
0 个点赞 | 4 个回复 | 问答 | 课程版本 5.7
anningri
ErrorException
0 个点赞 | 3 个回复 | 问答 | 课程版本 5.7
mingzaily
请问 Laravel-lang 包 404 页面或其他页面有问题
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.7
Gxpro
POST 请求总会变成 GET,求解原因?
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
arkylin
解决刷新后不生效问题
0 个点赞 | 1 个回复 | 分享 | 课程版本 8.x
Cyline
关于 Laravel 的另外一个语言包的分享
0 个点赞 | 1 个回复 | 分享 | 课程版本 5.5
YUKEY
按教程来的,最后中文显示的是 unicode 码这个怎么回事?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.8
esinger
这个包最新版本已经移除自动注册,教程里还没修改
0 个点赞 | 1 个回复 | 分享 | 课程版本 5.7
Striving
网页速度慢
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
shendu
Composer 来安装 Laravel-lang 出错
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
kakaxi
最新的语言包,caouecs已经弃用了
0 个点赞 | 0 个回复 | 分享 | 课程版本 7.x
xiaoyu03
安装完语言包,按教程修改了显示无法找到 overture 解决方案
0 个点赞 | 0 个回复 | 分享 | 课程版本 6.x
ziyouren
升级 Laravel 7 后所有异常白屏怎么破?
0 个点赞 | 0 个回复 | 问答 | 课程版本 6.x