33. 开发环境专属扩展包

说明

安装扩展包时,请区分是否 仅在开发中使用。例如我们只会在开发环境中使用 Laravel Debugbar,安装此扩展时我们应该使用以下命令:

$ composer require barryvdh/laravel-debugbar --dev

重点在 --dev 参数,这个告知 Composer 我们只会在开发环境中使用,Composer 会将依赖写入到 composer.json 里的 require-dev 选项里,我们现在的 Larabbs 项目里,此选项的内容如下:

"require-dev": {
    "barryvdh/laravel-debugbar": "~3.2",
    "facade/ignition": "^1.4",
    "fzaninotto/faker": "^1.4",
    "laravel/ui": "^1.0",
    "mockery/mockery": "^1.0",
    "nunomaduro/collision": "^3.0",
    "phpunit/phpunit": "^8.0",
    "summerblue/generator": "6.*"
},

当我们将项目部署到服务器时,配合使用以下命令:

$ composer install --no-dev

以上 --no-dev 参数指定 Composer 略过 require-dev...

本文章首发在 LearnKu.com 网站上。

为了保证课程的高品质,我们需要对课程进行收费。付费后 才能观看剩余内容。 购买

上一篇 下一篇
《L01 基础入门》
我们将带你从零开发一个项目并部署到线上,本课程教授 Web 开发中专业、实用的技能,如 Git 工作流、Laravel Mix 前端工作流等。
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
讨论数量: 0

暂无话题~