3.1. 初识 WePY

初识 WePY

使用原生的方式开发小程序,需要四个文件的配置:

  • .json ——配置文件;
  • .wxml —— 模板文件,类似 HTML;
  • .wxss —— 样式文件,类似 CSS;
  • .js —— 交互逻辑。

如果你熟悉 Web 开发,那么不难想到 HTML,CSS,JS 文件之间的相互配合,使用原生的小程序开发比较繁琐,类比现在的 Web 开发,你会引入 Bootstrap 解决页面布局和样式;使用 MVVM 的 Vue/React/Angular 等前端框架;使用 Less/Sass 编写样式;使用 ES6/ES7 的新特性;使用组件化开发等等;你一定希望有一些好用的工具提升开发效率。那么对于小程序来说,有没有这样的工具呢?——首先我们需要了解的就是 WePY。

WePY 是一个小程序组件化开发框架,开发风格接近 Vue.js,更贴近于 MVVM 架构模式,相比小程序原生开发要更加的方便快捷。

本文章首发在 LearnKu.com 网站上。

为了保证课程的高品质,我们需要对课程进行收费。付费后 才能观看剩余内容。 购买

上一篇 下一篇
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
讨论数量: 30

zzjdy_0
执行 yarn 出错了,什么原因?
2 个点赞 | 4 个回复 | 问答 | 课程版本 5.5
sayhe110
小程序初始化后报入口 app.json 文件没找到错误?
1 个点赞 | 9 个回复 | 问答 | 课程版本 5.5
宋高峰
WePY2.1安装过程踩坑+被迫增加第二个HomesteadBox的完整记录
1 个点赞 | 2 个回复 | 分享 | 课程版本 2.0
wepy init standard 失败的解决办法
1 个点赞 | 1 个回复 | 分享 | 课程版本 1.7
Fykex
不会自动弹出授权窗口,需要手动添加按钮
1 个点赞 | 1 个回复 | 分享 | 课程版本 5.5
晨读秀
wepy 初始化错误?
0 个点赞 | 10 个回复 | 问答 | 课程版本 5.5
haha
wepy init standard 初始化项目失败
0 个点赞 | 8 个回复 | 问答 | 课程版本 2.0
finding
初始化 yarn 报错了,包没找到?
0 个点赞 | 6 个回复 | 问答 | 课程版本 5.5
宋高峰
作者,请问您能不能提供一个WePY2的成功作品?
0 个点赞 | 5 个回复 | 问答 | 课程版本 2.0
phpervip
sudo yarn global add wepy-cli 后报 node 版本不对
0 个点赞 | 5 个回复 | 分享 | 课程版本 2.0
putixin
Windows 下开发?
0 个点赞 | 5 个回复 | 问答 | 课程版本 5.5
jamesquery
正常安装完 sudo yarn global add wepy-cli 后一直无法使用 wepy 命令
0 个点赞 | 3 个回复 | 问答 | 课程版本 2.0
kirit0
执行 yarn 报错了?
0 个点赞 | 3 个回复 | 问答 | 课程版本 2.0
夜游人
执行 npm run dev 出问题了,请问这是什么情况?
0 个点赞 | 2 个回复 | 问答 | 课程版本 2.0
xll123
npm run dev '.' 不是内部或外部命令,也不是可运行的程序
0 个点赞 | 2 个回复 | 问答 | 课程版本 2.0
Athos
npm install报错
0 个点赞 | 2 个回复 | 分享 | 课程版本 2.0
WindyLater
初始化 wepy init 遇到问题
0 个点赞 | 2 个回复 | 问答 | 课程版本 2.0
ayauper
?运行 wepy build --watch 报错
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
wangsfox
为啥我初始化完就报错呢?
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
kitty
宋高峰
执行npm install @wepy/cli -g出现报错
0 个点赞 | 1 个回复 | 问答 | 课程版本 2.0
d1270469522
文中的 > 是不是 应该换成 $
0 个点赞 | 1 个回复 | 问答 | 课程版本 2.0
Lion-
NPM install wepy-cli -g 您写成 insatll 了
0 个点赞 | 1 个回复 | 问答 | 课程版本 2.0
putixin
yarn 升级?
0 个点赞 | 1 个回复 | 分享 | 课程版本 5.5
hedeqiang
教程中这个运行在哪?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
道生一
npm install @wepy/cli -g 报错的解决措施
0 个点赞 | 0 个回复 | 分享 | 课程版本 2.0
运行 wepy build --watch 出现错误
0 个点赞 | 0 个回复 | 问答 | 课程版本 5.5