使用gorm连接 oracle库,运行时报错

1. 运行环境

go1.19+windows10(oracle环境已安装,环境变量已配置,mingw64都已安装)

以下是我使用的每三方包

github.com/cengsin/oracle v1.0.0
gorm.io/gorm v1.23.8
github.com/godror/godror v0.34.0

2. 问题描述?

之前本地开发(windows)连接oracle库,打linux包时godror会报错(期间因为用不到也一直没有去管它),结果现在在运行时都无法正常运行了(错误如下图)。网上能找的资料几乎已经找完了,还是没有解决问题,希望有经验的大佬帮忙看看这是什么问题导致的,感激不尽

使用gorm连接 oracle库,运行时报错

讨论数量: 5

,文件大小写问题导致的吧

1周前 评论
想飞的猿 (楼主) 1周前
DianWang

尝试降低go版本试试?

1周前 评论
想飞的猿 (楼主) 1周前

摸索出了一个解决方案 1:go版本降至 1.18 2:gorm版本降至 v1.21.16 3:env 参数 go env CGO_ENABLED=1

1周前 评论

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!