使用新版本的java实现usart通讯可行吗?

刚开始学习java,现在学以致用,工作中会用到串口调试设备,想着用java做个上位机,同时可以加深对java的兴趣,百度了好多资料,最终选择使用rxtxcomm包,跟着查到的资料一步一步做,最后会出现:

Problematic frame:

C [rxtxSerial.dll+0x5b00]

然后又百度了一下,大多人都推荐降低java版本。
我现在迷茫了,如果动不动就要降低版本才能实现,那么新版本学着还有意义吗?
希望有人可以帮忙解惑。不胜感激!

讨论数量: 2

:joy: Java1.8用的最多

1个月前 评论

但是你得考虑兼容啊,要么修改自己的代码使之兼容第三方包,要么替代原作者修改第三方包源码使之兼容自己的代码

1个月前 评论

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!