yarn install 及 yarn run dev 问题合集

执行 安装命令的时候,可能会出现下面问题:
yarn install --no-bin-links
运行上面命令,可能出现的问题:
错误一:
file

这种情况的话,加上sudo可以解决这个问题,我猜想应该是权限的问题

sudo yarn install --no-bin-links

错误二:
file
这个我也不知道是什么原因导致文件无法顺利复制到指定目录,这里我们手动复制,错误里已经指出需要复制的文件,及复制到什么目录,将前面一个路径的文件,复制到后面一个目录
cp 源文件(前面一个路径的文件) 目的目录(后面的目录)
之后重新执行安装命令,就可以了。

错误三:
file
它需要 autoconf libtool pkg-config nasm
为了编译,但是它构建了一个共享的二进制文件,需要libpng16-dev来运行。
所以需要先安装 libpng16-env:
sudo apt-get install libpng16-dev
参考:https://github.com/imagemin/imagemin-mozjp...


yarn run dev
运行上面命令出现的错误:
错误一:
cross-env : not found.
由于 homestead box 操作系统是 linux,而 cross-env 是为解决 windows下的环境变量差异,所以不需要安装。
将 package.json 中关于cross-env的字样删除:
file
完成,重新操作。

以上错误都是亲身经历,折腾了老半天,总结发出来,希望帮助到后面学习 Laravel 的同道。

本帖已被设为精华帖!
本帖由 Summer 于 2年前 加精
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 1

error An unexpected error occurred: "EPROTO: protocol error, symlink '../../../parser/bin/babel-parser.js' -> '/home/vagrant/Code/weibo/node_modules/@babel/core/node_modules/.bin/parser'".
前面的路径并不存在,该如何处理

1年前 评论
guanw2014 1年前
nullable 1年前

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!