brew 安装 yarn 后 PHP 无法使用?
1

file

昨天按照小程序的教程brew安装完yarn后,执行php -v开始报错。

dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.61.dylib Referenced from: /usr/local/sbin/php Reason: image not found [1] 67152 abort php -v

在网上能找到的方法全试过,都无效。有大神遇到类型问题么?求指教。

《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 2
Destiny

https://github.com/Homebrew/homebrew-core/issues/11713

这个问题是 php 依赖于 icu4c 开源组件,你把 php 卸载新安装一次就可以了。

6个月前
Destiny

yarn 也依赖于 icu4c 安装 yarn 的时候把 icu4c 给更新了。php 依赖的老版本 icu4c 找不到,你 重新安装一次 php

6个月前

  • 请注意单词拼写,以及中英文排版,参考此页
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`, 更多语法请见这里 Markdown 语法
  • 支持表情,使用方法请见 Emoji 自动补全来咯,可用的 Emoji 请见 :metal: :point_right: Emoji 列表 :star: :sparkles:
  • 上传图片, 支持拖拽和剪切板黏贴上传, 格式限制 - jpg, png, gif
  • 发布框支持本地存储功能,会在内容变更时保存,「提交」按钮点击时清空
  请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!