Laravel/passport 安装失败?

执行 composer require laravel/passport=~4.0
file

1.上面提示需要league/oauth2-server ^6.0,执行 composer require league/oauth2-server=~6.0
file
这里提示依赖paragonie/random_compat ^2.0版本

而我们执行composer info 可以看到我们这边的paragonie/random_compat 是^9.99.99版本
file

而这个9.99.99版本应该是在项目根目录下的composer.lock文件
file
好像也是其他的包所依赖的

这里就是2.0和9.99.99两个版本冲突了,导致安装失败,求解决办法

《L01 基础入门》
我们将带你从零开发一个项目并部署到线上,本课程教授 Web 开发中专业、实用的技能,如 Git 工作流、Laravel Mix 前端工作流等。
《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
讨论数量: 5
月殇

composer require paragonie/random_compat=~2.0
composer require laravel/passport=~4.0

11个月前 评论
jltxwesley

在 Laravel 5.6 下都是可以安装 Passport v4 的 (最新的版本是 v7)

file

你先用 composer show -t 或者在 composer.lock 里去找到哪个包在使用 paragonie/random_compat 最新的 v9 版本(你最后一张图片只是找到了这个包而已,你去找下哪个包在用它),看能不能把那个包换成低一点的版本:github 里去查看哪个版本是使用 paragonie/random_compat v2 的,这样就可以解决冲突了。

11个月前 评论

@jltxwesley 其他的包依赖paragonie/random_compat都是像下面三个版本都可以,但是他这边默认9.99.99版本,改也改不掉

file

11个月前 评论
jltxwesley

@else

这个会默认用最新的版本,不过这个包没有旧的版本 - 只显示用 1.0 和 2.0的?

或者我觉得这样应该可以解决问题:

你把这个用 v9 的包先用 composer 删除了,然后安装 passport(它会默认用 paragonie/random_compat v2),再安装之前删除的这个包就行了(compoer 会发现 v2 已经安装,就不会安装 v9 了)。

11个月前 评论

file
我给他降级了以后安装成功了

11个月前 评论
月殇

composer require paragonie/random_compat=~2.0
composer require laravel/passport=~4.0

11个月前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!