Destroying VM and associated drives... 这一步出现错误?

==> homestead-7: Destroying VM and associated drives...
C:/HashiCorp/Vagrant/embedded/gems/2.1.1/gems/vagrant-2.1.1/plugins/provisioners/shell/provisioner.rb:226:in gsub': invalid byte sequence in GBK (ArgumentError) from C:/HashiCorp/Vagrant/embedded/gems/2.1.1/gems/vagrant-2.1.1/plugins/provisioners/shell/provisioner.rb:226:inquote_and_escape'
from C:/HashiCorp/Vagrant/embedded/gems/2.1.1/gems/vagrant-2.1.1/plugins/provisioners/shell/provisioner.rb:17:in `block in provision'

有同学这步出问题的话,告诉下解决方案

《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
讨论数量: 3

我也遇到了同样的问题 你搞好了没有啊?

2年前 评论

怎么解决的...求解

通过在Vagrantfile中编写“ Encoding.default_external ='UTF-8'”解决了该问题。\
我不知道它是如何工作的> <\

Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
  ...
  Encoding.default_external = 'UTF-8'

  config.vm.provision "shell" , path: "setup.sh"
  ...
end

原文地址 http://dqn.sakusakutto.jp/2014/02/vagrant_...

1年前 评论

我是初次启动时目录内有个项目代码,就报一样错了,删了重新启动就ok了

1年前 评论

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!