windos 安装 Laravel/horizon 怎么安装呢?

本地环境是windows+php的 但是安装 laravel/horizon 的时候报错,需要添加一个

composer require laravel/horizon

PCNTL的扩展,而此扩展只支持 linux系列,那么我应该安装那个版本呢?

windos安装 laravel/horizon 怎么安装呢?

《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
最佳答案

在你的 composer.json 中增加以下两个字段:"platform": { "ext-pcntl": "7.2", "ext-posix": "7.2"},增加至 config 字段中,再次运行安装命令即可~

1周前 评论
liuhaiqiang999 (楼主) 1周前
蜗牛 1周前
lddtime 1周前
菜就多努力呀n (作者) 1周前
讨论数量: 3

在你的 composer.json 中增加以下两个字段:"platform": { "ext-pcntl": "7.2", "ext-posix": "7.2"},增加至 config 字段中,再次运行安装命令即可~

1周前 评论
liuhaiqiang999 (楼主) 1周前
蜗牛 1周前
lddtime 1周前
菜就多努力呀n (作者) 1周前

在你的 composer.json 中增加以下两个字段:"platform": { "ext-pcntl": "7.2", "ext-posix": "7.2"},增加至 config 字段中,再次运行安装命令即可~

1周前 评论
liuhaiqiang999 (楼主) 1周前
蜗牛 1周前
lddtime 1周前
菜就多努力呀n (作者) 1周前

虽然windows下开发比较方便一些,但是真就不知道哪天会用到什么在windows下没有东西。为了这我忍痛放弃了phpstrom,换成了 vs code 远程开发 + centos虚拟机(Hyper-v)。

phpstrom虽然有同步远程服务器文件的功能,但是还是依赖本地的环境配置,还有诸多小问题存在。

vs code的远程开发则完全不一样,所有操作都是在远程环境中执行,完全不用担心有什么扩展没有。而且laravel想要性能飞跃只能靠常驻内存解决,换句话说就是依靠swoole,而且swoole在windows上用于生产环境还是不太行。

虽然php方面 vs code远不如phpstrom,但是迫于各方的考虑还是长痛不如短痛了。

1周前 评论
菜就多努力呀n 1周前
菜就多努力呀n 1周前

不是应该使用homestead进行开发么

1周前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!