Composer update 异常

当前运行php版本7.2,在执行composer update 时出现异常
PHP Parse error: syntax error, unexpected '?' vendor/laravel/framework/src/Illuminate/Foundation/helpers.php on line 233
"require": {
"php": ">=7.0.0",
}

《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
最佳答案

直译:

PHP 解析错误,语法错误,意外(非预期)的 '?'(问号),出现在文件 vendor/laravel/framework/src/Illuminate/Foundation/helpers.php 的第 233 行,,,

解释:

由于这个文件是扩展里的,不是你写的(除非你改过),所以几乎可以肯定,是 PHP 版本不对,,,

3个月前 评论
讨论数量: 3

PHP版本低是不是?

3个月前 评论

@hehehehe laravel5.5 php7.2.15

3个月前 评论

直译:

PHP 解析错误,语法错误,意外(非预期)的 '?'(问号),出现在文件 vendor/laravel/framework/src/Illuminate/Foundation/helpers.php 的第 233 行,,,

解释:

由于这个文件是扩展里的,不是你写的(除非你改过),所以几乎可以肯定,是 PHP 版本不对,,,

3个月前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!