Laravel7 在最新 Homestead 下运行提示 500 错误!

laravel7在最新homestead下运行提示500错误!
这个是配置

laravel7在最新homestead下运行提示500错误!
我新建了一个info.php直接访问没有问题

laravel7在最新homestead下运行提示500错误!
这里显示的是7.1
但我用的php -v 显示的是7.4

laravel7在最新homestead下运行提示500错误!
说明web服务这个应该是没有问题。
网上找资料让看看到storage的日志文件

laravel7在最新homestead下运行提示500错误!
local.ERROR: Declaration of Carbon\Translator::setLocale($locale) must be compatible with Symfony\Contracts\Translation\LocaleAwareInterface::setLocale(string $locale) {“exception”:”[object]
提示这个错误,有人说是版本原因,我在homestead里改成了7.4还是不行,这下就不明白了

《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
最佳答案

看了一下你这个问题,PHP的运行环境有两个,一个是cli 和cgi,你指定的应该是cli 环境下的版本,php7.1和7.4还是有差异的,比如解构赋值,你这个报错肯定是版本差异导致的。解决方案如下

  1. vagrant ssh 登录到shell
  2. sudo vim /etc/nginx/sites-enable/homestead.test
  3. 找到php7.1-fpm 改成 php7.4-fpm
  4. sudo systemctl restart nginx 大功告成
3天前 评论
msmax (楼主) 3天前
讨论数量: 8

php7.1 执行一下 应该就改成了 7.1版本了

6天前 评论

file

file php - v显示的是7.4,用phpinfo显示出来是7.1 用update-alternatives –config php,改了下版本好像还是不生效。

4天前 评论
bing8u

楼主,你好大的胆子!

居然敢用 type: "nfs" 参数

用它 问题多多,要么是不可写,不可读,不可执行等,composer update 还不能更新。反正等你发掘

4天前 评论
msmax (楼主) 4天前
leo 4天前
bing8u (作者) 3天前
archy 3天前

实在不行,就用个集成环境得了。

3天前 评论

看了一下你这个问题,PHP的运行环境有两个,一个是cli 和cgi,你指定的应该是cli 环境下的版本,php7.1和7.4还是有差异的,比如解构赋值,你这个报错肯定是版本差异导致的。解决方案如下

  1. vagrant ssh 登录到shell
  2. sudo vim /etc/nginx/sites-enable/homestead.test
  3. 找到php7.1-fpm 改成 php7.4-fpm
  4. sudo systemctl restart nginx 大功告成
3天前 评论
msmax (楼主) 3天前

forders 下的map 使用绝对路径

3天前 评论

file 绝对靠谱,就是这个问题

file 这里把版本改成最高的

3天前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!