phpstrom 代码不支持:?语法

请教各位大神:在PHPSTROM 10.0.3中,语法代码:?不支持应该怎么处理?

《L01 基础入门》
我们将带你从零开发一个项目并部署到线上,本课程教授 Web 开发中专业、实用的技能,如 Git 工作流、Laravel Mix 前端工作流等。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 12

你 php 是什么版本

2个月前 评论
cxmiamomu (楼主) 2个月前

你这种写法我第一次看到,是真的php语法吗?

2个月前 评论
Nick

可以看下 composer.json 文件中是否限制了 php 版本

2个月前 评论
Nick
2个月前 评论
qf-Z 2个月前

要在phpstorm里面设置下php版本 file

2个月前 评论

是不是 PHPSTROM 版本太低,我这的提示是:

file

2个月前 评论
cxmiamomu (楼主) 2个月前
yxuefeng (作者) 2个月前
cxmiamomu (楼主) 2个月前

估计是phpstorm版本太低了。

2个月前 评论
cxmiamomu (楼主) 2个月前
cxmiamomu (楼主) 2个月前

调整 composer 里面的 PHP 版本

2个月前 评论
cxmiamomu (楼主) 2个月前

首先感谢各位的支持!
我的phpstorm 版本信息,composer.json中的php版本控制还有语法提示的截图发出来,希望大家再帮忙一把!
phpstrom版本信息
file
语法提示
file
phpstorm中关于语言最低级别,只能选择到7,在interpreter选择的是7.3.5
file
composer.json中php版本控制为7.1.3
file

环境版本

Laravel

感谢为盼!

2个月前 评论

你这是直接复制来的吧

2个月前 评论
cxmiamomu (楼主) 2个月前

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!