PHP 多版本配置有问题?

homestead-virtualbox-3.0.0 是支持不同站指定不同 php 版本配置的,但如果使用 v5.4.0 的 Homestead 会导致配置失效,官方配置使用的是 v6.1.0 版本,没有此问题。如果大家只是学习或者没有多php版本的需求,可以忽略以下内容。

切换 homestead

cd ~

git clone https://github.com/laravel/homestead.git Homestead

cd Homestead

// Clone the desired release...
git checkout v6.1.0

// ...

站点配置

sites:
    - map: homestead.test
      to: /home/vagrant/Code/Laravel/public
      php: "5.6"

命令行下操作

php5.6 artisan list
php7.0 artisan list
php7.1 artisan list
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
讨论数量: 5

重启了 vagrant reload --provision 也不好使 ,PHP的版本没有变,而且 那几个命令显示没有唉 怎么回事? 求大神制指点。

2年前 评论

我使用的版本是 v5.2.6

2年前 评论
程序猴的进化史

同求 我这边也是想在CLI 切换版本测试功能 发现一直是7.1

2年前 评论

@程序猴的进化史 请问解决了?我也遇到了这类问题,切换版本 一重启就默认回了7.1

2年前 评论
程序猴的进化史

@gaoxiang 目前开发 Docker 没用 homestead了,不过配置好后,估计需要进入 vagrant ssh 里面站点项目目录才会PHP版本不一样。

2年前 评论

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!