请问下,python3 在使用 aiokafka 的时候出现了模块缺少异常,步骤以及准备按照 GitHub

请问下,python3在使用aiokafka的时候出现了模块缺少异常,步骤以及准备按照github
python3版本:3.6.3
kafka版本:1.0.2
github地址:https://github.com/aio-libs/aiokafka
报错:cannot import name ‘ConsumerRebalanceListener’
缺少ConsumerRebalanceListener,查看源码中也不存在这个ConsumerRebalanceListener,可是kafka版本与git的测试要求版本一致,求解

讨论数量: 4

你用pip重装kafta,看看能不能安装一个最新版本

5天前 评论
Jason990420

不知道你从哪看的, kafka 版本要1.0.2, 我查了一下, 好像ConsumerRebalanceListener是从1.3.2版本才有的. 建议你用最新版试试 pip install --upgrade kafka-python

Python 3.8.1 (tags/v3.8.1:1b293b6, Dec 18 2019, 23:11:46) [MSC v.1916 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> from kafka import ConsumerRebalanceListener as BaseConsumerRebalanceListener
>>>
5天前 评论

@TNT_God

file出现了新的错误,请帮忙看一下

7小时前 评论
TNT_God 3小时前

@Jason990420 一开始是从它的官方git上看的,写的1.0.2,我现在改为新版了,出现了新的错误

file

7小时前 评论

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!