ubutun20.04 安装报 未满足的依赖关系

系统:ubutun20.04

root@song-Inspiron-7737:~# openssl version
OpenSSL 1.1.1f  31 Mar 2020
root@song-Inspiron-7737:~# ^C
root@song-Inspiron-7737:~# python3 -V
Python 3.8.5
root@song-Inspiron-7737:~# pip3 -V
pip 20.0.2 from /usr/lib/python3/dist-packages/pip (python 3.8)

安装

sudo apt install python3-dev python3-pip libssl-dev build-essential python3-venv

报错

libssl-dev 已经是最新版 (1.1.1f-1ubuntu2.4)。
python3-pip 已经是最新版 (20.0.2-5ubuntu1.5)。
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 build-essential : 依赖: libc6-dev 但是它将不会被安装 或
                           libc-dev
                   依赖: g++ (>= 4:9.2) 但是它将不会被安装
 python3-dev : 依赖: libpython3-dev (= 3.8.2-0ubuntu2) 但是它将不会被安装
               依赖: python3.8-dev (>= 3.8.2-1~) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
一个奋斗者
最佳答案

参考链接1:www.codeprj.com/blog/abd4cc1.html 使用 aptitude 安装你需要的那些库。

参考链接2:blog.csdn.net/qq_39346534/article/... 更新一下Ubuntu的源。然后整体更新一下,再安装试一下。

3周前 评论
songbai (楼主) 3周前
讨论数量: 1

参考链接1:www.codeprj.com/blog/abd4cc1.html 使用 aptitude 安装你需要的那些库。

参考链接2:blog.csdn.net/qq_39346534/article/... 更新一下Ubuntu的源。然后整体更新一下,再安装试一下。

3周前 评论
songbai (楼主) 3周前

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!