关于使用 Laravel new 新项目 报错的问题

场景: laravel5.8,window10,php7.2.19
报错: composesr安装扩展的时候报 Failed to execute unzip(其实就是没有zip的扩展,它无法解压下载的扩展,我尝试去pecl中下载ZIP 扩展DLL,发现并没有什么卵用)
分析和解决的办法: 我使用了composer多线程下载的扩展包(hirak/prestissimo),因为是全局安装的,其原理就是下到缓存,然后以后全部都走缓存安装。所以我第一件事 先全局卸载掉它

composer global remove hirak/prestissimo

然后清空当前composer的缓存

composer clear-cache

然后使用laravel new blog, 你会发现没有报错了。


PS:后来经过测试和扩展没什么关系,主要是我原先主要是5.7版本的,缓存也是.所以理论上来说,只要清除composer的缓存就好。( ̄_, ̄ )

以上是window下遇到的问题,linux没有发现。

希望对你们遇到的这个坑有帮助。

本作品采用《CC 协议》,转载必须注明作者和本文链接
《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 0
(= ̄ω ̄=)··· 暂无内容!

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!