5.2. 代码生成器

说明

在『Laravel 教程』系列课程中,我们开发时遵守的代码风格是 Laravel 项目开发规范。遵照此规范,在实际操作中,有许多重复,接下来推荐一款专为此规范量身定制的代码生成器 —— Laravel 5.x Scaffold Generator 。代码生成器能让你通过执行一条 Artisan 命令,完成注册路由、新建模型、新建表单验证类、新建资源控制器以及所需视图文件等任务,不仅约束了项目开发的风格,还能极大地提高我们的开发效率。

在接下来的 LaraBBS 项目开发中,我们将利用此扩展来快速构建项目原型。

后续章节我们将『Laravel 5.x Scaffold Generator』简称为『代码生成器』,或者『生成器』。

安装

1. 通过 Composer 安装

$ composer require "summerblue/generator:~1.0" --dev

后置参数 --dev 表明我们只在开发环境中使用。

2. 版本标记

本小节剩下的篇幅中,我们将带大家来测试下代码生成器,熟悉...

本文章首发在 LearnKu.com 网站上。

为了保证课程的高品质,我们需要对课程进行收费。付费后 才能观看剩余内容。 购买

上一篇 下一篇
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
讨论数量: 12

wangji
一定要用 Laravel 5.x Scaffold Generator 这个包吗?
2 个点赞 | 7 个回复 | 问答 | 课程版本 5.5
abing
Composer require 'summerblue/generator:~0.5' --dev 的问题?
2 个点赞 | 4 个回复 | 问答 | 课程版本 5.5
zgy0777
[已解决] 关于 Composer 安装第三方包失败引起一系列的问题
0 个点赞 | 5 个回复 | 问答 | 课程版本 5.5
tim-laravel
没有使用 Git 在这里发现不能还原了,是不是废了?
0 个点赞 | 4 个回复 | 问答 | 课程版本 5.5
darkness
Laravel 5.x Scaffold Generator 安装包不能正确生成视图?
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
rigg
make:scaffold 后出错?
0 个点赞 | 2 个回复 | 问答 | 课程版本 5.5
nullable
不能安装'summerblue/generator'?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
pigzzz
为何代码生成器(summerblue/generator)不能通过 compose 安装?
0 个点赞 | 1 个回复 | 问答 | 课程版本 5.5
laoniutoushan