yarn add promise-polyfill 出错怎么办?

error An unexpected error occurred: "EPROTO: protocol error, symlink '../acorn/bin/acorn' -> '/home/vagrant/Code/-larabbs-weapp/node_modules/acorn-jsx/node_modules/.bin/acorn'".

《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 21

解决方案 : yarn add promise-polyfill --no-bin-links
成功的点个赞

8个月前
liyu001989

提供一下你的环境信息吧,yarn, node 的版本

https://github.com/yarnpkg/yarn/issues/4908

是不是 npm install --no-bin-links ?

9个月前

@liyu001989 ,环境是w10+VM 5.2.6+vagrant 2.0.2 yarn 和 node 是 教程定制包集成的,尝试了将项目中的 node_modules 删除,运行 npm install --no-bin-links 和 sudo yarn install --no-bin-links cmd窗口不报错了。但是小程序Cannot read property 'then' of undefined;at App lifeCycleMethod onLaunch function
TypeError: Cannot read property 'then' of undefined 报错依旧存在。

9个月前
liyu001989

你都用 vagrant了 为什么不使用 homestead,yarn --version node --version ,看一下版本。编译的时候报错?截图请截报错的完整的窗口,多给点信息

9个月前

@liyu001989 多谢指教!下面这是报错图

file

file

9个月前
liyu001989

yarn 已经 1.7 了,node升级到 node/8.11.3

9个月前

@liyu001989 依旧出错,换了电脑好了 :joy:

9个月前

@liyu001989 如何升级yarn呀?百度了很多资料都没有成功升级yarn。我也出现了同样的问题。求大神指点下。 :pray:

file

9个月前

@JasonLWF sudo npm upgrade --global yarn

9个月前

@tont

file还是升级失败呀。 :joy:

9个月前

@JasonLWF 卸了重装试试 npm uninstall -g yarn && npm install -g yarn

9个月前

@tont

file
还是失败呀,好头疼呀,这问题。 :joy: :grin:

9个月前

@JasonLWF 等待大神回复吧,可能是电脑问题。

9个月前

@tont @liyu001989 原来是系统缓存的原因,我已经升级到yarn最新版本了,我刚重新启动Homestead虚拟机,就发现已经升级到yarn最新版本1.7.0了,问题已经解决。感谢回复呀!

file

9个月前

@JasonLWFyarn add promise-polyfill 还报错么?

9个月前
queuingant

看了评论还是没搞懂这个问题是怎么解决的

8个月前
Vicer

一脸懵逼的看完,然后无奈的去重启试试

8个月前

解决方案 : yarn add promise-polyfill --no-bin-links
成功的点个赞

8个月前

@liyu001989 请问node在homestead中如何升级?谢谢!

8个月前
liyu001989

@putixin n nvm npm apt 直接下载,就是个 ubuntu 怎么升级都行

8个月前

@liyu001989 知道了,好像提示找不到 n 命令

8个月前

@Chring 成功了

6个月前

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!