MacOS Mojave 系统 - Vagrant nfs export 问题 和 字体变得超细 的解决方案

如果你最近升级了 Mac 系统,在运行 homestead up 的时候遇到如下的错误:

tee: /etc/exports: Operation not permitted
tee: /etc/exports: Operation not permitted
tee: /etc/exports: Operation not permitted
The nfsd service does not appear to be running.
Starting the nfsd service
==> homestead-7: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o vers=3,udp,actimeo=1,nolock 192.168.10.1:/Users/***/*** /home/vagrant/***

Stdout from the command:

Stderr from the command:

mount.nfs: Connection timed out

解决方案请参考这个链接:https://github.com/hashicorp/vagrant/issue...

也就是确保以下的权限设置:
file
file


如果你发现系统的字体变得 super thin,比如 VS Code 里,请在命令行终端里运行:defaults write -g CGFontRenderingFontSmoothingDisabled -bool NO

jltxwesley
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
《G01 Go 实战入门》
从零开始带你一步步开发一个 Go 博客项目,让你在最短的时间内学会使用 Go 进行编码。项目结构很大程度上参考了 Laravel。
讨论数量: 4

重启command+R

打开终端 运行:csrutil disable

重启电脑,也能解决

3年前 评论

Mac 下面为何不用 Valet

3年前 评论
jltxwesley

@vasar

也就 developer 会 disable 掉 System Integrity Protection :smile: 其实它毕竟多一层安全保护。

3年前 评论

解决方法很赞

3年前 评论

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!