使用laravel sail后如何在新电脑上使用docker部署环境

目前遇到的问题,新电脑下载docker后,想要运行sail up必须得先composer install,而电脑本地的php为7.3,无法composer。
如何通过docker在任何电脑上git clone后都能统一环境呢?

《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 2

为现有应用程序安装 Composer 依赖项 Sail 开发环境《Laravel 8 中文文档》

3个月前 评论
Noctis (楼主) 3个月前
Noctis (楼主) 3个月前
Noctis (楼主) 3个月前

composer --ignore-platform-reqs 不会影响你的操作

3个月前 评论
xcz196 3个月前

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!