sail 启动的时候报错(已经好几天了还是没解决..)

执行./vendor/bin/sail up报错,如下
已经更换过很多个国内源了。。一直卡在这一步..求大佬或者有遇到过的告知下,网上搜索了很多也没解决。。。
“php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed”
这个libc6依赖要求是2.33更高的版本,但是20.04装不了2.33…你们有出现这个情况吗?

#9 34.23 The following packages have unmet dependencies:
#9 34.27  php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.8.0) but it is not going to be installed
#9 34.27  php8.0-common : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                  Depends: libffi8ubuntu1 (>= 3.4~20200819) but it is not installable
#9 34.27  php8.0-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
#9 34.27  php8.0-opcache : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-pcov : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-soap : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                Depends: libxml2 (>= 2.7.4) but it is not going to be installed
#9 34.27  php8.0-swoole : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xdebug : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xml : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.9.0) but it is not going to be installed
#9 34.27               Depends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
#9 34.27  php8.0-zip : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libzip4 (>= 1.7.0) but it is not installable
#9 34.28 E: Unable to correct problems, you have held broken packages
#9 34.23 The following packages have unmet dependencies:
#9 34.27  php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.8.0) but it is not going to be installed
#9 34.27  php8.0-common : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                  Depends: libffi8ubuntu1 (>= 3.4~20200819) but it is not installable
#9 34.27  php8.0-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
#9 34.27  php8.0-opcache : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-pcov : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-soap : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                Depends: libxml2 (>= 2.7.4) but it is not going to be installed
#9 34.27  php8.0-swoole : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xdebug : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xml : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.9.0) but it is not going to be installed
#9 34.27               Depends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
#9 34.27  php8.0-zip : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libzip4 (>= 1.7.0) but it is not installable
#9 34.28 E: Unable to correct problems, you have held broken packages.
#9 34.23 The following packages have unmet dependencies:
#9 34.27  php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.8.0) but it is not going to be installed
#9 34.27  php8.0-common : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                  Depends: libffi8ubuntu1 (>= 3.4~20200819) but it is not installable
#9 34.27  php8.0-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
#9 34.27  php8.0-opcache : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-pcov : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-soap : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                Depends: libxml2 (>= 2.7.4) but it is not going to be installed
#9 34.27  php8.0-swoole : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xdebug : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xml : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.9.0) but it is not going to be installed
#9 34.27               Depends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
#9 34.27  php8.0-zip : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libzip4 (>= 1.7.0) but it is not installable
#9 34.28 E: Unable to correct problems, you have held broken packages.
``````php
#9 34.23 The following packages have unmet dependencies:
#9 34.27  php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.8.0) but it is not going to be installed
#9 34.27  php8.0-common : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                  Depends: libffi8ubuntu1 (>= 3.4~20200819) but it is not installable
#9 34.27  php8.0-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
#9 34.27  php8.0-opcache : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-pcov : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-soap : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                Depends: libxml2 (>= 2.7.4) but it is not going to be installed
#9 34.27  php8.0-swoole : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xdebug : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xml : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.9.0) but it is not going to be installed
#9 34.27               Depends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
#9 34.27  php8.0-zip : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libzip4 (>= 1.7.0) but it is not installable
#9 34.28 E: Unable to correct problems, you have held broken packages.
#9 34.23 The following packages have unmet dependencies:
#9 34.27  php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.8.0) but it is not going to be installed
#9 34.27  php8.0-common : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                  Depends: libffi8ubuntu1 (>= 3.4~20200819) but it is not installable
#9 34.27  php8.0-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
#9 34.27  php8.0-opcache : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-pcov : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-soap : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                Depends: libxml2 (>= 2.7.4) but it is not going to be installed
#9 34.27  php8.0-swoole : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xdebug : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xml : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.9.0) but it is not going to be installed
#9 34.27               Depends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
#9 34.27  php8.0-zip : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libzip4 (>= 1.7.0) but it is not installable
#9 34.28 E: Unable to correct problems, you have held broken packages.
#9 34.23 The following packages have unmet dependencies:
#9 34.27  php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.8.0) but it is not going to be installed
#9 34.27  php8.0-common : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                  Depends: libffi8ubuntu1 (>= 3.4~20200819) but it is not installable
#9 34.27  php8.0-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
#9 34.27  php8.0-opcache : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-pcov : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-soap : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                Depends: libxml2 (>= 2.7.4) but it is not going to be installed
#9 34.27  php8.0-swoole : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xdebug : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xml : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.9.0) but it is not going to be installed
#9 34.27               Depends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
#9 34.27  php8.0-zip : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libzip4 (>= 1.7.0) but it is not installable
#9 34.28 E: Unable to correct problems, you have held broken packages.
#9 34.23 The following packages have unmet dependencies:
#9 34.27  php8.0-cli : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.8.0) but it is not going to be installed
#9 34.27  php8.0-common : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                  Depends: libffi8ubuntu1 (>= 3.4~20200819) but it is not installable
#9 34.27  php8.0-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
#9 34.27  php8.0-opcache : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-pcov : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-soap : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27                Depends: libxml2 (>= 2.7.4) but it is not going to be installed
#9 34.27  php8.0-swoole : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xdebug : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27  php8.0-xml : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libxml2 (>= 2.9.0) but it is not going to be installed
#9 34.27               Depends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
#9 34.27  php8.0-zip : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
#9 34.27               Depends: libzip4 (>= 1.7.0) but it is not installable
#9 34.28 E: Unable to correct problems, you have held broken packages.
《L02 从零构建论坛系统》
以构建论坛项目 LaraBBS 为线索,展开对 Laravel 框架的全面学习。应用程序架构思路贴近 Laravel 框架的设计哲学。
《L04 微信小程序从零到发布》
从小程序个人账户申请开始,带你一步步进行开发一个微信小程序,直到提交微信控制台上线发布。
讨论数量: 3

没看我那天回复了一个 issues 链接?不试试

2周前 评论
Katrigeng (楼主) 2周前
myhui0926

其实解决办法很简单,就是不要定制 Dockerfile 。但是你需要自己解决网络问题,需要使用 TUN 模式的 ladder。不过我计划将构建好的镜像导出来共享一下,看看能不能行。

1周前 评论
Katrigeng (楼主) 1周前

为什么不试试可爱的7.4呢?

1周前 评论
Katrigeng (楼主) 1周前

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!