composer update更新报错: Your requirements could not be resolved to an installable set of packages. 求解决!

更新laravel项目里的composer的依赖包

使用命令: composer update 报错

$ composer update
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires laravel-admin-ext/media-browser ^2.0, found laravel-admin-ext/media-browser[2.0] in the lock file but not in remote repositories, make sure you avoid updating this package to keep the one from the lock file.
  Problem 2
    - Root composer.json requires bringyourownideas/laravel-sitemap ^2.1 -> satisfiable by bringyourownideas/laravel-sitemap[2.1.0].
    - bringyourownideas/laravel-sitemap 2.1.0 requires guzzlehttp/guzzle ^7.0 -> found guzzlehttp/guzzle[dev-master, 7.0.0-beta.1, ..., 7.4.x-dev (alias of dev-master)] but it conflicts with your root composer.json require (^6.3).
  Problem 3
    - Root composer.json requires laravelium/sitemap 2.7.* -> satisfiable by laravelium/sitemap[v2.7.2, v2.7.3, 2.7.x-dev].
    - Conclusion: don't install laravel/framework v7.0.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.3 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.4 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.5 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.6 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.7 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.8 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.1.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.1.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.1.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.1.3 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.2.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.2.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.2.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.3.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.4.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.5.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.5.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.5.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.6.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.6.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.6.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.7.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.7.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.8.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.8.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.9.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.9.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.9.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.10.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.10.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.10.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.10.3 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.11.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.12.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.13.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.14.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.14.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.15.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.16.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.16.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.17.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.17.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.17.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.18.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.19.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.19.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.20.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.21.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.22.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.22.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.22.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.22.3 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.22.4 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.23.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.23.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.23.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.24.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.25.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.26.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.26.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.27.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.28.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.28.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.28.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.28.3 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.28.4 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.29.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.29.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.29.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.29.3 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.30.0 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.30.1 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.30.2 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.30.3 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.30.4 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.30.5 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.30.6 (conflict analysis result)
    - Conclusion: don't install laravel/framework v7.0.0 (conflict analysis result)
    - laravelium/sitemap[v2.7.2, ..., 2.7.x-dev] require illuminate/support 5.5.* -> satisfiable by illuminate/support[v5.5.0, ..., 5.5.x-dev].
    - Only one of these can be installed: illuminate/support[v5.5.0, ..., 5.8.x-dev, v6.0.0, ..., 6.x-dev, v7.0.0, ..., 7.x-dev, v8.0.0, ..., 8.x-dev, v9.0.0-beta.1, ..., 9.x-dev], laravel/framework[v7.0.0, ..., 7.x-dev]. laravel/framework replaces illuminate/support and thus cannot coexist with it.
    - Root composer.json requires laravel/framework ^7.0 -> satisfiable by laravel/framework[v7.0.0, ..., 7.x-dev].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

网上找了解决方案:

执行 composer install --ignore-platform-reqs或者 composer update --ignore-platform-reqs

经过测试没有效果,求解决方法

《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
《G01 Go 实战入门》
从零开始带你一步步开发一个 Go 博客项目,让你在最短的时间内学会使用 Go 进行编码。项目结构很大程度上参考了 Laravel。
讨论数量: 5

你这个。应该是 包版本 和 laravel 版本不匹配导致的,要找匹配的包

2周前 评论

不要轻易的使用 compser update 命令!!

安装扩展包的命令是 composer install !!

2周前 评论
xiaochong0302 2周前

如果是你自己新建的项目就删除 composer.lock 文件,然后执行 composer install

2周前 评论

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!