EasyAdmin8-Laravel 更新 Laravel 11.x 版本,PHP限制 >= 8.2.0

EasyAdmin8-LaravelEasyAdmin 的基础上使用 Laravel 11.x 重构,PHP 最低版本要求不低于 8.2

请注意:当前项目采用 laravel 11.x 构建,如需要 laravel 10.x 请在分支中选择 10.x

Laravel v11.x 和 layui v2.9.x 的快速开发的后台管理系统。

项目地址:easyadmin8.top

main 分支演示地址:laravel.easyadmin8.top/admin,需要 PHP >=8.2

10.x 分支演示地址:laravel-10.easyadmin8.top/admin,需要 PHP >=8.1

新功能

  • 主要更新 Laravel 版本,PHP 版本要求提升
  • 旧版 Laravel 10.x 依赖,归入 10.x 分支

安装教程

EasyAdmin8-Laravel 使用 Composer 来管理项目依赖。因此,在使用 EasyAdmin8-Laravel 之前,请确保你的机器已经安装了 Composer。

通过 git 下载安装包,composer 安装依赖包

1.下载安装包

git clone github.com/wolf-leo/EasyAdmin8-Lar...

或者

git clone gitee.com/wolf18/EasyAdmin8-Larave...

2.安装依赖包(确保 PHP 版本 >= 8.2 如需要本地上传则须装 fileinfo 扩展)

在根目录下 composer install ,如果有报错信息可以使用命令 composer install –ignore-platform-reqs

3.拷贝 .example.env 文件重命名为 .env ,命令 cp .example.env .env ,修改数据库账号密码参数

4.设置 APP_KEY ,命令 php artisan key:generate

5.命令启动(php artisan serve)或者配置伪静态(以 Nginx 为例)

location / {
try_files $uri $uri/ /index.php$is_args$query_string;
}

预览图

人生一场虚空大梦,韶华白首,不过转瞬。惟有BUG恒在,往复循环,不曾更改。
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
《G01 Go 实战入门》
从零开始带你一步步开发一个 Go 博客项目,让你在最短的时间内学会使用 Go 进行编码。项目结构很大程度上参考了 Laravel。
讨论数量: 13

新开源的?

1个月前 评论
wolfcode (楼主) 1个月前

我看如果开发的话,后台的blade文件是需要自己一个个写的对吧

1个月前 评论
wolfcode (楼主) 1个月前
如此甚好 (作者) 1个月前
如此甚好 (作者) 1个月前
wolfcode (楼主) 1个月前

有个小建议,获取配置参数用config() 来代替 env(),之前用octane 加速踩过这个坑,例如这个

file

1个月前 评论
wolfcode (楼主) 1个月前
www295686243 1个月前
lun1bz 1个月前
wolfcode (楼主) 1个月前
wolfcode (楼主) 1个月前

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!