go run 无法运行

我在执行 go run xxx 命令的时候,提示以下信息,我使用的是 gvm go1.18版本

ld: warning: '/private/var/folders/nf/f4bk5n4s1mz_06rp5590ddww0000gn/T/go-link-1578785919/go.o' has malformed LC_DYSYMTAB, expected 114 undefined symbols to start at index 25522, found 128 undefined symbols starting at index 74

各种目录的权限也给了,就是不行,我的电脑上mac m3的,折磨我好久了,求救啊

麦迪文
讨论数量: 11

自己从 go 官方下载一个安装试下不就行了,,

4周前 评论
麦迪文 (楼主) 4周前
翟宇鑫

删掉 gvm
使用 brew unlink 和 brew link

4周前 评论
翟宇鑫 (作者) 4周前
麦迪文 (楼主) 4周前
麦迪文 (楼主) 4周前
tonyzhang329 3周前

file

哥们儿,idea或者goland是支持多版本go切换的啊,不用gvm一样的跑的飞起,我司项目用1.15~1.18,我自己的小玩意儿用1.22,自如切换

4周前 评论
麦迪文 (楼主) 4周前

这错误信息一看就是错误的动态连接库引用,为啥不用 docker ?😂

3周前 评论
tonyzhang329 3周前

讨论应以学习和精进为目的。请勿发布不友善或者负能量的内容,与人为善,比聪明更重要!